Posts Tagged ‘ problem

Problem z widgetem Like Box – Facebook

Jakiś czas temu na jednej ze stron pojawił się problem z widgetem Like Box udostępnianym przez Facebook. Problem dość nietypowy ponieważ w miejscu gdzie zazwyczaj widniały znajome z Facebooka twarze pojawił się napis „The page you are trying to access is restricted or unavailable” ( na groźnie wyglądającym czerwonym tle ). Problem oczywiście był niespodziewany, Like Box działał na stronie już dłuższy czas i ani on ani Fun Page nie był zmieniany.

The page you are trying to access is restricted or unavailable

Informacja w miejscu / zamiast "Like Box"

Na forum developerów facebookowych aplikacji nie udało mi się znaleźć pomocnych informacji, to co znalazłem wyjaśniało ogólną przyczynę – sytuację w której zwracany jest taki komunikat błędu. Komunikat o takim błędzie powinien być zwracany jeżeli Fun Page powiązany z widgetem Like Box ma restrykcyjne ograniczenia wiekowe lub ograniczenia co do kraju w którym można oglądać dany Fun Page. Ustawienia te można zmienić w „Edytuj stronę ->  Zarządzaj uprawnieniami”. Czytaj dalej

[Rozwiązany] WordPress MultiSite + Domain Mapping – wolne działanie

RozwiązanieOd dłuższego czasu mam przyjemność prowadzenia paru stron z pomocą WordPress MultiSite. Niestety pomimo optymalizacji kodu / grafiki strony działające na silniku WordPress w wersji MultiSite, ładowały się wolniej ( około 1900 ms – całość strony ) od tych działających na standardowych instalacjach ( 800 ms ). Początkowo jednak nie przejmowałem się tym zbytnio, zrzucając winę na obciążony już znacznie serwer. Byłem też  przekonany, że pokazywany na wykresie średni czas pobierania strony ( Google Narzędzia dla Webmasterów ) ulegnie znaczniej zmianie po aktywowaniu wtyczki WP Super Cache. Niestety nawet precyzyjne ustawienie tego dodatku ( z zaznaczeniem opcji wspierania pluginu WordPress MU Domain Mapping ) nie przyniosło dobrych rezultatów.

Pierwsza część planu, uruchomienie cachowania, nie przyniosła efektów. Postanowiłem więc trochę dokładniej sprawdzić przyczyny i zlokalizować wolno działający kawałek kodu. Okazało się, że w pewnej konfiguracji wtyczek oraz ich ustawień dzieją się dziwne rzeczy.

Czytaj dalej

Problem z instalacja WordPress na serwerach Strefa.pl

Dla wszystkich, którzy posiadają wykupiony hosting na serwerach Strefa.pl a którzy chcieli by zainstalować ( lub zaktualizować ) tam najnowszą wersję WordPress ‘a mam złe wiadomości. Po ostatnich próbach zaktualizowania jednej ze stron, która znajduje się właśnie na serwerach Strefy.pl okazało się, że serwer nie spełnia wymagań. Dokładniej, WordPress do poprawnego działania potrzebuje PHP 4.3 i MySQL 4.1.2 ( a na Strefa.pl jest PHP 4.2.2 i MySQL 5.0.72 ). Ostatnia działająca tam wersja to WordPress 2.8.4, do pobrania z archiwum WordPress. Dość nieprzyjemna informacja, szczególnie jeżeli dowiadujemy się o tym w momencie próby aktualizacji silnika naszej strony :(

Czytaj dalej

Przecinek w nazwie kolumny a red cross error na wykresie

Niedawno miałem nieprzyjemność borykania się z problemem „czerwonego krzyża” wyświetlanego na wykresach ( Chart , System.Windows.Forms.DataVisualization.Charting ). Błąd ten pojawia się m.in. przy problemach z przetworzeniem danych wejściowych. W moim przypadku przyczyną problemów były przecinki w nazwach kolumn obiektu DataTable, który to ustawiałem jako DataSource dla wykresu.

Dokładnie: Wartości w nazwach kolumn, które znajdowały się po przecinku były „ignorowane” w DataSource. Skutkiem tego nazwy kolumn w DataSource nie zgadzały się z tymi w DataTable, w moim przypadku parę kolumn miało tę samą nazwę ( co jest oczywistym błędem).

red cross error csharp chart

:)

Problem z uruchomieniem aplikacji skompilowanej za pomocą Visial Studio 2008

Jakiś czas temu pracowaliśmy nad aplikacją wykorzystującą bibliotekę OpenCV do sterowania grą Pong za pomocą kamery. Cała aplikacja tworzona była w środowisku Visual Studio 2008. Po skompilowaniu działającego programu do wersji Release nie chciał on działać na innych komputerach ( z tym samym systemem operacyjnym ). Natychmiast po uruchomieniu wyświetlany był komunikat błędu:

"The application failed to initialize properly  (0xc0150002). Click on OK to terminate the  application"

Rozwiązanie błędu było tak proste, że aż wstyd o nim pisać :) Okazało się bowiem, że w czasie kompilowania linkowaliśmy biblioteki OpenCV w wersji Debug. Wystarczyło tylko zmienić linkowane biblioteki na odpowiednia wersję alby problem znikł.

Partnerzy Pro: