Dwa słowa o wymaganiach WordPress

Zastanawiającym jest fakt nie umieszczenia w wymaganiach jakie musi spełniać serwer, na którym chcemy zainstalować WordPress ‚a , informacji o wymaganej minimalnej dostępnej pamięci. W wymaganiach podanych na stronie brakuje informacji o tym, że wskazane jest posiadanie 64mb pamięci na serwerze.

Brak wystarczającej pamięci objawi się nam poprzez sporadyczne wyświetlanie pustej strony, dopiero z logów serwera dowiemy się o występowaniu błędu:

Fatal error: Allowed memory size of …

Informacja taka powinna być podawana w wymaganiach, szczególnie że błędy które generowane są przez brak pamięci mogą objawiać się sporadycznie, a nie każdy przegląda regularnie logi serwera.

Automatyczna aktualizacja WordPress

Średnio dwa razy do roku ( wliczając poprawki 9 razy ) WordPress Team udostępnia nam nową wersję silnika WordPress. Nowe wersje przynoszą poza dodatkowymi funkcjonalnościami, poprawki i łatki znalezionych błędów. Aktualizacja silnika   jest więc wskazana, ale nie oznacza to że nasza strona nie będzie bez niej funkcjonować… Mamy natomiast zestaw wtyczek, bez których nasza strona może wiele stracić. Należy więc przed aktualizacją sprawdzić czy wszystkie używane dodatki, albo przynajmniej te najważniejsze będą w nowej wersji poprawnie działały. Na oficjalnej stronie WordPress’a znaleźć można poradnik, który poprowadzi nas przez proces aktualizacji. Co powinniśmy zrobić:

1. Sprawdzenie wymagań nowej wersji

Wymagania jakie musi spełniać nasz serwer nie są wygórowane,  powinniśmy jednak przed instalacją sprawdzić wymagania najnowszej wersji WordPress. W 99% przypadków ten punkt jest zbędny, jednak zawsze istnieje ten 1% ( np. serwery strefa.pl ) dla którego to może nam on zaoszczędzić czas na robieniu backup ‚u i późniejszym przywracaniu działającej wersji. Warto więc poświęcić 5 min na sprawdzenie wymagań. Parametry serwera powinniśmy znaleźć w jego panelu administracyjnym, natomiast wymagania WP są podawana na stronie z najnowszą wersją.

Czytaj dalej Automatyczna aktualizacja WordPress

Warte uwagi wtyczki do WordPress

Kontynuując temat wartych uwagi wtyczek do WordPress, chciałbym podzielić się z Wami kolejnymi znaleziskami. Wymienione poniżej pluginy mogą nie przydać się na każdej stronie, dodają jednak ciekawe funkcjonalności.


1. Collapsing Archives

wordpress.org…collapsing-archives

Wtyczka umożliwia dostosowanie wyglądu archiwum strony.

Jeżeli prowadzisz blog od dłuższego czasu, standardowy wygląd archiwum artykułów może odstraszać użytkowników. Dodatek Collapsing Archives grupuje artykuły w miesiące i lata, z pomocą JavaScriptu tworzy też rozwijane menu. Domyślnie „otwarte” jest archiwum aktualnego miesiąca.

WP Plugin Collapsing Archives w użyciu
WP Plugin Collapsing Archives w użyciu

Czytaj dalej Warte uwagi wtyczki do WordPress

Rozwiązanie problemu z SI CAPTCHA Anti-Spam

Błąd SI CAPTCHA Anti-Spam a może mój? Tak czy inaczej rozwiązywałem dziś problem z dodatkiem do WordPress SI CAPTCHA Anti-Spam. Na swojej stronie w czasie próby wysłania poprawnego komentarza ( z kodem CAPTCHA ) otrzymywałem błąd:

ERROR: Could not read CAPTCHA cookie. Make sure you have cookies
enabled and not blocking in your web browser settings.
Or another plugin  is conflicting.

Wyruszyłem więc na poszukiwanie przyczyny błędu. Nie znalazłem niestety rozwiązania w FAQ wtyczki oraz na forum WordPress, nie pomogło też wyłączenie wszystkich innych dodatków. Po przeanalizowaniu kodu pluginu okazało się, że przytoczony komunikat błędu może dotyczyć także problemów z sesją.

Przyczyna błędu:

Różne adresy blogu w „Ustawieniach -> Ogólne”„Adres URL WordPressa” i „Adres URL blogu” ). Sesja była tworzona dla adresu „Adres URL blogu” a formularz komentarzy przesyłany był pod „Adres URL WordPressa”.

Rozwiązanie:

Czytaj dalej Rozwiązanie problemu z SI CAPTCHA Anti-Spam